summaryrefslogtreecommitdiff
path: root/shm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'shm/meson.build')
-rw-r--r--shm/meson.build12
1 files changed, 1 insertions, 11 deletions
diff --git a/shm/meson.build b/shm/meson.build
index 01ced55..d904cd0 100644
--- a/shm/meson.build
+++ b/shm/meson.build
@@ -1,19 +1,9 @@
-name = meson.project_name() + '-shm'
-
sources = files('dconf-shm.c')
cflags = '-DG_LOG_DOMAIN="@0@"'.format(meson.project_name())
libdconf_shm = static_library(
- name,
- sources: sources,
- include_directories: top_inc,
- dependencies: glib_dep,
- c_args: cflags
-)
-
-libdconf_shm_shared = static_library(
- name + '-shared',
+ meson.project_name() + '-shm',
sources: sources,
include_directories: top_inc,
dependencies: glib_dep,