summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 960d72c..6de67b5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,6 +3,7 @@ include $(top_srcdir)/Makefile.gtester
AM_CFLAGS = -std=c89 -Wall -Wmissing-prototypes -Wwrite-strings -DSRCDIR=\"$(abs_srcdir)\"
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/engine -I$(top_srcdir)/client $(gio_CFLAGS) -I$(top_srcdir)/dbus-1 $(dbus_CFLAGS) -I$(top_srcdir)/gvdb
+noinst_LIBRARIES = libdconf-dbus-stub.a
noinst_PROGRAMS = $(TEST_PROGS) gsettings dbus1
gsettings_LDADD = $(gio_LIBS)
@@ -12,6 +13,26 @@ TEST_PROGS += paths
paths_LDADD = ../common/libdconf-common.a $(gio_LIBS)
paths_SOURCES = paths.c
+engine_LIBS = \
+ ../engine/libdconf-engine.a \
+ ../common/libdconf-common.a
+
+engine_with_stub_LIBS = \
+ $(engine_LIBS) \
+ libdconf-dbus-stub.a
+
+client_LIBS = \
+ ../client/libdconf-client.a \
+ $(engine_LIBS) \
+ ../gdbus/libdconf-gdbus.a
+
+stub_client_LIBS = \
+ ../client/libdconf-client.a \
+ $(engine_with_stub_LIBS)
+
+libdconf_dbus_stub_a_SOURCES = \
+ dconf-dbus-stub.c
+
TEST_PROGS += gvdb
gvdb_LDADD = $(glib_LIBS)
gvdb_SOURCES = \