summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6737a97..0ec6cbe 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -10,6 +10,11 @@ libdconf_mock = static_library(
dependencies: glib_dep
)
+envs = test_env + [
+ 'G_TEST_SRCDIR=' + meson.current_source_dir(),
+ 'G_TEST_BUILDDIR=' + meson.current_build_dir(),
+]
+
test_dir = meson.current_source_dir()
dl_dep = cc.find_library('dl', required: false)
@@ -36,5 +41,5 @@ foreach unit_test: unit_tests
link_with: unit_test[4]
)
- test(unit_test[0], exe, is_parallel: false)
+ test(unit_test[0], exe, is_parallel: false, env: envs)
endforeach