summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcyli <cyli@twistedmatrix.com>2017-05-22 15:45:06 -0700
committerJoffrey F <f.joffrey@gmail.com>2017-08-15 15:45:51 -0700
commitc163375591f075c641804effbfa65be5cd08adce (patch)
tree26be227c0ad5087607d0e0456bb71e981b67f0c6 /setup.py
parent3b95da3ea48c3f60f133cdefe1382fce5d44a770 (diff)
downloaddocker-py-c163375591f075c641804effbfa65be5cd08adce.tar.gz
If we're pinning exact versions of things for requirements.txt, pin
all dependencies of dependencies as well so we can get a consistent build. Signed-off-by: cyli <cyli@twistedmatrix.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 534c949..4a33c8d 100644
--- a/setup.py
+++ b/setup.py
@@ -36,10 +36,10 @@ extras_require = {
# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
':python_version < "3.3"': 'ipaddress >= 1.0.16',
- # If using docker-py over TLS, highly recommend this option is pip-installed
- # or pinned.
+ # If using docker-py over TLS, highly recommend this option is
+ # pip-installed or pinned.
- # TODO: if pip installign both "requests" and "requests[security]", the
+ # TODO: if pip installing both "requests" and "requests[security]", the
# extra package from the "security" option are not installed (see
# https://github.com/pypa/pip/issues/4391). Once that's fixed, instead of
# installing the extra dependencies, install the following instead: