summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBen Firshman <ben@firshman.co.uk>2016-11-23 15:02:59 +0000
committerBen Firshman <ben@firshman.co.uk>2016-11-28 15:11:01 +0000
commit6d770a65d7c05d708334a93ee3bdb099061447de (patch)
treead43364bb115674ff70c06960470342c18116dfb /setup.py
parent04e943798691ba2663b91eaedd8ae2410f016d2c (diff)
downloaddocker-py-6d770a65d7c05d708334a93ee3bdb099061447de.tar.gz
Use find_packages in setup.py
It was missing docker.models, and this will fix it forever more. Signed-off-by: Ben Firshman <ben@firshman.co.uk>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c311370..edf4b0e 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
import os
import sys
-from setuptools import setup
+from setuptools import setup, find_packages
ROOT_DIR = os.path.dirname(__file__)
@@ -48,10 +48,7 @@ setup(
description="A Python library for the Docker Engine API.",
long_description=long_description,
url='https://github.com/docker/docker-py',
- packages=[
- 'docker', 'docker.api', 'docker.transport', 'docker.utils',
- 'docker.types',
- ],
+ packages=find_packages(exclude=["tests.*", "tests"]),
install_requires=requirements,
tests_require=test_requirements,
extras_require=extras_require,