summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2016-04-08 00:20:42 +0800
committerFelix Yan <felixonmars@archlinux.org>2016-04-08 00:36:46 +0800
commit9da54931355c5ac7146e1f2b137a12cbbb190cfa (patch)
tree989117d4ce5732c32dab9947502c3d2210da5c9e /setup.py
parentfdd118706a1e63cc22821e6610cfd861eca1f7b9 (diff)
downloaddocker-py-9da54931355c5ac7146e1f2b137a12cbbb190cfa.tar.gz
Use backports.ssl_match_hostname
The py2-ipaddress module unfortunately conflicts with the pypi:ipaddress module, which is in the dependency tree of widely used pyOpenSSL. I think it would be a good idea to use a well maintained backport of the Python 3.5 implementation of match_hostname() instead of duplicating the effort and maintain another. All tests are passing here. Signed-off-by: Felix Yan <felixonmars@archlinux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0329ba3..2be705d 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ requirements = [
]
extras_require = {
- ':python_version < "3"': 'py2-ipaddress >= 3.4.1',
+ ':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
}
exec(open('docker/version.py').read())