summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2012-05-29 21:57:48 +0000
committerVincent Torri <vincent.torri@gmail.com>2012-05-29 21:57:48 +0000
commit5555a288c8a3a1ca151ace60c6d21815fe0e790a (patch)
tree386a56aecc16128920d2fe6133fb183f1795ccff /configure.ac
parentdea1a2205fc4aa40b0344a6a36feba2c34bbd86f (diff)
downloadeina-5555a288c8a3a1ca151ace60c6d21815fe0e790a.tar.gz
Eina: remove threads options from configure
remove --disable-posix-threads and --disable-win32-threads from configure options, and detect automatically the threading support. SVN revision: 71517
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index fe7ab19..aa08632 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,19 +95,7 @@ EFL_CHECK_CPU_SSE([have_sse="yes"], [have_sse="no"])
EFL_CHECK_CPU_SSE2([have_sse2="yes"], [have_sse2="no"])
EFL_CHECK_CPU_ALTIVEC([have_altivec="yes"], [have_altivec="no"])
-EFL_CHECK_THREADS(
- [
- if test "x${_efl_have_posix_threads}" = "xyes" ; then
- have_threads="POSIX"
- else
- if test "x${_efl_have_win32_threads}" = "xyes" ; then
- have_threads="Win32"
- else
- have_threads="no"
- fi
- fi
- ],
- [have_threads="no"])
+EFL_CHECK_THREADS
EFL_CHECK_SPINLOCK([have_posix_threads_spinlock="yes"], [have_posix_threads_spinlock="no"])
if ! test "x${have_threads}" = "xno" ; then