summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2010-02-23 15:34:37 -0800
committerRoland McGrath <roland@redhat.com>2010-02-23 15:35:43 -0800
commit69556fcf845e9482e76c4817cce9902b8ab0f492 (patch)
tree9526a9ea05e182636f37015d046fc6ae2afb7538 /tests/Makefile.am
parent3eb92e40855f3179d8f05d333bc42c76bae747a8 (diff)
parentbc87bd74a6ecf7d8559c83c8047f5ed11e93f1fe (diff)
downloadelfutils-69556fcf845e9482e76c4817cce9902b8ab0f492.tar.gz
Merge commit 'origin/master' into dwarf
Conflicts: libdw/Makefile.am
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 8 insertions, 17 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 174fcce4..c7ce6d50 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to create Makefile.in
##
-## Copyright (C) 1996-2009 Red Hat, Inc.
+## Copyright (C) 1996-2010 Red Hat, Inc.
## This file is part of Red Hat elfutils.
##
## Red Hat elfutils is free software; you can redistribute it and/or modify
@@ -24,28 +24,22 @@
## Network licensing program, please visit www.openinventionnetwork.com
## <http://www.openinventionnetwork.com>.
##
-DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
+include $(top_srcdir)/config/eu.am
if MUDFLAP
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
- $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
BUILD_RPATH = \$$ORIGIN/../backends
else
-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
- $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
endif
-AM_CXXFLAGS = $(AM_CFLAGS:gnu99=gnu++0x)
-
AM_LDFLAGS =
if !STANDALONE
-INCLUDES = -I$(top_srcdir)/libasm -I$(top_srcdir)/libdw \
- -I$(top_srcdir)/libdwfl \
- -I$(top_srcdir)/libebl -I$(top_srcdir)/libelf \
- -I$(top_srcdir)/lib -I..
+INCLUDES += -I$(top_srcdir)/libasm -I$(top_srcdir)/libdw \
+ -I$(top_srcdir)/libdwfl \
+ -I$(top_srcdir)/libebl -I$(top_srcdir)/libelf \
+ -I$(top_srcdir)/lib -I..
AM_LDFLAGS += -Wl,-rpath-link,../libasm:../libdw:../libelf
-endif !STANDALONE
+endif
if TESTS_RPATH
AM_LDFLAGS += -Wl,-rpath,$(BUILT_RPATH)
@@ -170,7 +164,6 @@ endif !STANDALONE
if MUDFLAP
static_build = yes
-libmudflap = -lmudflap
endif
if STANDALONE
@@ -251,11 +244,9 @@ dwfl_bug_report_LDADD = $(libdw) $(libebl) $(libelf) $(libmudflap) -ldl
dwfl_bug_getmodules_LDADD = $(libdw) $(libebl) $(libelf) $(libmudflap) -ldl
dwfl_addr_sect_LDADD = $(libdw) $(libebl) $(libelf) $(libmudflap) -ldl
sha1_tst_LDADD = $(libeu) $(libmudflap)
-dwarf_getmacros_LDADD = $(libdw)
+dwarf_getmacros_LDADD = $(libdw) $(libmudflap)
addrcfi_LDADD = $(libdw) $(libebl) $(libelf) $(libmudflap) -ldl
-CLEANFILES = xxx *.gcno *.gcda *gconv
-
if GCOV
check: check-am coverage
.PHONY: coverage