summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-10-03 15:42:10 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-10-03 15:46:15 -0700
commitb5c965dbd8eef12e8e7c79e59d2fa58c2b8d60d7 (patch)
treee918cccbfd67763547e322bedb5c5d2533013fc9 /configure.ac
parentaf2a40fbd37a663a8ee5a722f9fecb80c425c128 (diff)
downloademacs-b5c965dbd8eef12e8e7c79e59d2fa58c2b8d60d7.tar.gz
Warn if --without-pop is now the default
* configure.ac (with_pop): Set to no-by-default if defaulting to "no". Warn about the change if defaulting to "no". Update URLs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3feac73bed3..d92b95cb545 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,7 +259,7 @@ AC_ARG_WITH([pop],
[],
[case $host in
*-mingw*) with_pop=yes;;
- *) with_pop=no;;
+ *) with_pop=no-by-default;;
esac])
if test "$with_pop" = yes; then
AC_DEFINE(MAIL_USE_POP)
@@ -1320,7 +1320,7 @@ dnl For a long time, -znocombreloc was added to LDFLAGS rather than
dnl LD_SWITCH_SYSTEM_TEMACS. That is:
dnl * inappropriate, as LDFLAGS is a user option but this is essential.
dnl Eg "make LDFLAGS=... all" could run into problems,
-dnl http://bugs.debian.org/684788
+dnl https://bugs.debian.org/684788
dnl * unnecessary, since temacs is the only thing that actually needs it.
dnl Indeed this is where it was originally, prior to:
dnl https://lists.gnu.org/archive/html/emacs-pretest-bug/2004-03/msg00170.html
@@ -1399,10 +1399,6 @@ case "$opsys" in
# The resulting binary has a complete symbol table, and is better
# for debugging and other observability tools (debuggers, pstack, etc).
#
- # If you encounter a problem using dldump(), please consider sending
- # a message to the OpenSolaris tools-linking mailing list:
- # http://mail.opensolaris.org/mailman/listinfo/tools-linking
- #
# It is likely that dldump() works with older Solaris too, but this has
# not been tested, so for now this change is for Solaris 10 or newer.
UNEXEC_OBJ=unexsol.o
@@ -2651,7 +2647,7 @@ if test x"$pkg_check_gtk" = xyes; then
closing open displays. This is no problem if you just use
one display, but if you use more than one and close one of them
Emacs may crash.
- See http://bugzilla.gnome.org/show_bug.cgi?id=85715]])
+ See https://bugzilla.gnome.org/show_bug.cgi?id=85715]])
fi
fi
@@ -4464,7 +4460,6 @@ emacs_broken_SIGIO=no
case $opsys in
dnl SIGIO exists, but the feature doesn't work in the way Emacs needs.
- dnl See eg <http://article.gmane.org/gmane.os.openbsd.ports/46831>.
hpux* | nacl | openbsd | sol2* | unixware )
emacs_broken_SIGIO=yes
;;
@@ -5575,6 +5570,12 @@ if test ! "$with_mailutils"; then
AC_MSG_WARN([This configuration installs a 'movemail' program
that retrieves POP3 email via only insecure channels.
To omit insecure POP3, you can use '$0 --without-pop'.])
+ elif test "$with_pop" = no-by-default; then
+ AC_MSG_WARN([This configuration installs a 'movemail' program
+that does not retrieve POP3 email. By default, Emacs 25 and earlier
+installed a 'movemail' program that retrieved POP3 email via only
+insecure channels, a practice that is no longer recommended but that
+you can continue to support by using '$0 --with-pop'.])
fi
case $opsys in
@@ -5586,7 +5587,7 @@ To omit insecure POP3, you can use '$0 --without-pop'.])
case `(movemail --version) 2>/dev/null` in
*Mailutils*) ;;
*) emacs_fix_movemail="install GNU Mailutils
-<http://mailutils.org> and $emacs_fix_movemail";;
+<https://mailutils.org> and $emacs_fix_movemail";;
esac
AC_MSG_NOTICE([You might want to $emacs_fix_movemail.]);;
esac