summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-12-08 00:53:49 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2013-12-08 00:53:49 -0800
commit3bc9da3286759f895574ecad3234ee3e0973e9df (patch)
treef3c83d49b330eb2764f6257185d3cc2284205d40 /configure.ac
parent27262e39e6a1da5db8cf0735615193efc49b9ad7 (diff)
downloademacs-3bc9da3286759f895574ecad3234ee3e0973e9df.tar.gz
* configure.ac: Simplify supression of GTK deprecation warning.
Move -DGDK_DISABLE_DEPRECATION_WARNINGS out of the command line and into config.h, to shorten the command line when doing 'make'. Don't AC_SUBST GTK_CFLAGS, as this is not needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 264c339ed6e..5240afac291 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2185,8 +2185,10 @@ if test "${opsys}" != "mingw32"; then
gtk_term_header=gtkutil.h
USE_GTK_TOOLKIT="GTK3"
if test "x$ac_enable_gtk_deprecation_warnings" = x; then
- GTK_CFLAGS="$GTK_CFLAGS -DGDK_DISABLE_DEPRECATION_WARNINGS"
- GTK_CFLAGS="$GTK_CFLAGS -DGLIB_DISABLE_DEPRECATION_WARNINGS"
+ AC_DEFINE([GDK_DISABLE_DEPRECATION_WARNINGS], [1],
+ [Define to 1 to disable GTK+/GDK deprecation warnings.])
+ AC_DEFINE([GLIB_DISABLE_DEPRECATION_WARNINGS], [1],
+ [Define to 1 to disable Glib deprecation warnings.])
fi
else
check_gtk2=yes
@@ -2212,7 +2214,6 @@ fi
if test x"$pkg_check_gtk" = xyes; then
- AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
C_SWITCH_X_SITE="$C_SWITCH_X_SITE $GTK_CFLAGS"
CFLAGS="$CFLAGS $GTK_CFLAGS"