summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-03-04 18:39:05 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2014-03-04 18:39:05 -0800
commit59587ee4559e791138ea55181834ca4cdd4e8270 (patch)
tree6a518fbbcfd4d9e6ad6b74742a34b0dbac72f378 /configure.ac
parent94a089b5f873837a369a176c114430e0fd0bee05 (diff)
downloademacs-59587ee4559e791138ea55181834ca4cdd4e8270.tar.gz
Fix configuration bug on Solaris 2.5.1.
* configure.ac: Fix a bug in shell pattern matching that caused 'configure' to treat Solaris 2.5.1 as if it were Solaris 10 or later. Fixes: debbugs:16896
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6a31fcb1b2b..f2a2186403c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -575,6 +575,10 @@ case "${canonical}" in
* ) unported=yes ;;
esac
case "${canonical}" in
+ *-sunos5.[1-9][0-9]* | *-solaris2.[1-9][0-9]* )
+ opsys=sol2-10
+ emacs_check_sunpro_c=yes
+ ;;
*-sunos5.6* | *-solaris2.6* )
opsys=sol2-6
RANLIB="ar -ts"
@@ -583,10 +587,6 @@ case "${canonical}" in
opsys=sol2-6
emacs_check_sunpro_c=yes
;;
- *-sunos5* | *-solaris* )
- opsys=sol2-10
- emacs_check_sunpro_c=yes
- ;;
esac
## Watch out for a compiler that we know will not work.
case "${canonical}" in