summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDani Moncayo <dmoncayo@gmail.com>2013-12-14 10:30:15 +0100
committerDani Moncayo <dmoncayo@gmail.com>2013-12-14 10:30:15 +0100
commit6084a28b66e4a3cedf860a58c342f5f60b7685e3 (patch)
tree2a941f28c81ae8b824cefb5ac4dad0bd01680962 /configure.ac
parent88927a8f62d6c183d8a3da9fc07018109712a315 (diff)
downloademacs-6084a28b66e4a3cedf860a58c342f5f60b7685e3.tar.gz
* configure.ac (srcdir) [MINGW32]: Convert to an absolute MSYS
path of the form "/c/foo/bar" to simplify conversion of formats.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 41258fcb7a9..2e9eee6b367 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,16 @@ dnl along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.65)
AC_INIT(emacs, 24.3.50)
-test "x$MSYSTEM" = "xMINGW32" && . $srcdir/nt/mingw-cfg.site
+if test "x$MSYSTEM" = "xMINGW32"
+then
+ . $srcdir/nt/mingw-cfg.site
+
+ # Convert srcdir to an absolute MSYS path of the form "/c/foo/bar"
+ # to simplify later conversions of paths to windows-native format
+ # "c:/foo/bar"
+ srcdir=`cd "${srcdir}" && pwd -W`
+ srcdir="/${srcdir:0:1}${srcdir:2}"
+fi
dnl Set emacs_config_options to the options of 'configure', quoted for the shell,
dnl and then quoted again for a C string. Separate options with spaces.