summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Colascione <dancol@dancol.org>2014-03-30 16:59:19 -0700
committerGlenn Morris <rgm@gnu.org>2014-03-30 16:59:19 -0700
commit8e86e380dc76be2e49f23c9bf7f28eda076875c7 (patch)
tree1004ba2480cbf9a9f86eed12cd07c49297b474bf /configure.ac
parent34cad8271df666d5f45431dba73eed02b2634657 (diff)
downloademacs-8e86e380dc76be2e49f23c9bf7f28eda076875c7.tar.gz
* configure.ac: Include GFILENOTIFY objects in glib check (backport from trunk)
Fixes: debbugs:17069
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44199c1fb50..971674bb3f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3851,6 +3851,10 @@ AC_CHECK_FUNCS(snprintf)
dnl Check this late. It depends on what other libraries (lrsvg, Gtk+ etc)
dnl Emacs uses.
XGSELOBJ=
+OLDCFLAGS="$CFLAGS"
+OLDLIBS="$LIBS"
+CFLAGS="$CFLAGS $GFILENOTIFY_CFLAGS"
+LIBS="$LIBS $GFILENOTIFY_LIBS"
AC_MSG_CHECKING([whether GLib is linked in])
AC_LINK_IFELSE([AC_LANG_PROGRAM(
[[#include <glib.h>
@@ -3865,6 +3869,8 @@ if test "${links_glib}" = "yes"; then
XGSELOBJ=xgselect.o
fi
fi
+CFLAGS="$OLDCFLAGS"
+LIBS="$OLDLIBS"
AC_SUBST(XGSELOBJ)
dnl Adapted from Haible's version.