summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-07-11 19:40:59 -0400
committerGlenn Morris <rgm@gnu.org>2012-07-11 19:40:59 -0400
commitee1cf5cfae709b340f49e8c5591fe1e782a6ac34 (patch)
tree92fc231e596c7b0b15e4c7a7efc9f743f573c95b /configure.ac
parenta464a6c73acf27b0d633d428919a36bc16a9d442 (diff)
downloademacs-ee1cf5cfae709b340f49e8c5591fe1e782a6ac34.tar.gz
All platforms using configure support HAVE_PTYS and HAVE_SOCKETS
* configure.ac (HAVE_PTYS, HAVE_SOCKETS): Define unconditionally. * src/s/aix4-2.h, src/s/bsd-common.h, src/s/cygwin.h, src/s/darwin.h: * src/s/gnu-linux.h, src/s/hpux10-20.h, src/s/template.h: * src/s/usg5-4-common.h: Move HAVE_PTYS and HAVE_SOCKETS to configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6029635e24..9ec7ebcd08a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3132,6 +3132,18 @@ AC_DEFINE(CLASH_DETECTION, 1, [Define if you want lock files to be written,
so that Emacs can tell instantly when you try to modify a file that
someone else has modified in his/her Emacs.])
+dnl Everybody supports this, except MS.
+dnl Seems like the kind of thing we should be testing for, though.
+## Note: PTYs are broken on darwin <6. Use at your own risk.
+AC_DEFINE(HAVE_PTYS, 1, [Define if the system supports pty devices.])
+
+dnl Everybody supports this, except MS-DOS.
+dnl Seems like the kind of thing we should be testing for, though.
+dnl Compare with HAVE_INET_SOCKETS (which is unused...) above.
+AC_DEFINE(HAVE_SOCKETS, 1, [Define if the system supports
+ 4.2-compatible sockets.])
+
+
case $opsys in
darwin | gnu | hpux* | *bsd )
AC_DEFINE(NO_TERMIO, 1, [Define if termio.h should not be included.])