summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-03-17 22:26:56 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2013-03-17 22:26:56 -0700
commit19151a7f8ce7452ff9a4c84aa18dd7de60ce0fc1 (patch)
tree7e6f8e5c324c1ac5604c22d25b0b52df97f458d9 /configure.ac
parent982efbcdc4b44d595743cf9085ad64731417cde3 (diff)
downloademacs-19151a7f8ce7452ff9a4c84aa18dd7de60ce0fc1.tar.gz
Emacs crashes with ImageMagick 6.8.2-3 through 6.8.3-9.
* configure.ac (IMAGEMAGICK_MODULE): Reject 6.8.2. We want to reject 6.8.2-3 through 6.8.3-9, but there seems to be no way to do this in pkg-config, so make do with a reasonable approximation. * etc/PROBLEMS: Mention problem with ImageMagick 6.8.2-3 through 6.8.3-9. Fixes: debbugs:13867
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d1f31032a9..d6c730c5033 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1880,7 +1880,8 @@ if test "${HAVE_X11}" = "yes"; then
## 6.2.8 is the earliest version known to work, but earlier versions
## might work - let us know if you find one.
## 6.0.7 does not work. See bug#7955.
- IMAGEMAGICK_MODULE="Wand >= 6.2.8"
+ ## 6.8.2 makes Emacs crash; see Bug#13867.
+ IMAGEMAGICK_MODULE="Wand >= 6.2.8 Wand != 6.8.2"
PKG_CHECK_MODULES(IMAGEMAGICK, $IMAGEMAGICK_MODULE, HAVE_IMAGEMAGICK=yes, :)
AC_SUBST(IMAGEMAGICK_CFLAGS)
AC_SUBST(IMAGEMAGICK_LIBS)