summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-12-27 09:59:21 -0800
committerGlenn Morris <rgm@gnu.org>2012-12-27 09:59:21 -0800
commit60f5e585bd5a94ddce429a5271640293afa53089 (patch)
tree9b82bb8778a830c2a751ba1db4542611ad15f5c6 /configure.ac
parentfd146719cb0b98b278ad428006383d865f3696cf (diff)
downloademacs-60f5e585bd5a94ddce429a5271640293afa53089.tar.gz
configure.ac fix for double quotes in configure command-line
* configure.ac (emacs_config_options): New. Use $@ rather than undocumented $ac_configure_args. Replace any embedded double quotes. Fixes: debbugs:13274
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9e0582dee6b..429443c2c24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,9 @@ dnl along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.65)
AC_INIT(emacs, 24.3.50)
+dnl This is the documented way to record the args passed to configure,
+dnl rather than $ac_configure_args.
+emacs_config_options="$@"
AC_CONFIG_HEADER(src/config.h:src/config.in)
AC_CONFIG_SRCDIR(src/lisp.h)
AC_CONFIG_AUX_DIR(build-aux)
@@ -4068,7 +4071,9 @@ fi
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}",
[Define to the canonical Emacs configuration name.])
-AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}",
+dnl Replace any embedded " characters (bug#13274).
+emacs_config_options=`echo "$emacs_config_options" | sed -e "s/\"/'/g"`
+AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${emacs_config_options}",
[Define to the options passed to configure.])
AH_TEMPLATE(config_opsysfile, [Some platforms that do not use configure
define this to include extra configuration information.])