summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Colascione <dancol@dancol.org>2012-12-10 09:52:35 -0800
committerDaniel Colascione <dancol@dancol.org>2012-12-10 09:52:35 -0800
commit743fa5cbdd42a820c4320599a14aab925dcdbc8b (patch)
tree7c330bf115347bbb0fa87b59f88c87a50745d432 /configure.ac
parent98a07056558be8c13945a3a99b4801996af685a4 (diff)
parent1cf1bbd51e91f02a1d3fabb4f7ea4b1322c4259c (diff)
downloademacs-743fa5cbdd42a820c4320599a14aab925dcdbc8b.tar.gz
Move fix for cygw32 icon issue from emacs-24 branch to trunk as Stefan Monnier requests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index abdf515144b..6f188a54bd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1606,6 +1606,8 @@ AC_SUBST(LIB_STANDARD)
HAVE_W32=no
W32_OBJ=
W32_LIBS=
+W32_RES=
+W32_RES_LINK=
if test "${with_w32}" != no; then
if test "${opsys}" != "cygwin"; then
AC_MSG_ERROR([Using w32 with an autotools build is only supported for Cygwin.])
@@ -1614,13 +1616,21 @@ if test "${with_w32}" != no; then
[AC_MSG_ERROR([`--with-w32' was specified, but windows.h
cannot be found.])])
AC_DEFINE(HAVE_NTGUI, 1, [Define to use native MS Windows GUI.])
+ AC_CHECK_TOOL(WINDRES, [windres],
+ [AC_MSG_ERROR([No resource compiler found.])])
W32_OBJ="w32fns.o w32menu.o w32reg.o w32font.o w32term.o"
W32_OBJ="$W32_OBJ w32xfns.o w32select.o w32uniscribe.o"
W32_LIBS="$W32_LIBS -lkernel32 -luser32 -lgdi32 -lole32 -lcomdlg32"
W32_LIBS="$W32_LIBS -lusp10 -lcomctl32 -lwinspool"
+ W32_RES="emacs.res"
+ # Tell the linker that emacs.res is an object (which we compile from
+ # the rc file), not a linker script.
+ W32_RES_LINK="-Wl,-bpe-i386 -Wl,emacs.res"
fi
AC_SUBST(W32_OBJ)
AC_SUBST(W32_LIBS)
+AC_SUBST(W32_RES)
+AC_SUBST(W32_RES_LINK)
if test "${HAVE_W32}" = "yes"; then
window_system=w32