summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2016-02-26 08:22:36 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2016-02-26 08:23:26 -0800
commite35f99f2dd35a89b42961fc63c7e2772fb03c792 (patch)
tree42737bbd0e7f64d9b6840516b202f0aa914db098 /configure.ac
parent9583b9e871f89bdc1bf30c24a2090c08ed87e1b5 (diff)
downloademacs-e35f99f2dd35a89b42961fc63c7e2772fb03c792.tar.gz
--enable-gcc-warnings now uses -Wjump-misses-init
When configuring with --enable-gcc-warnings, also enable -Wjump-misses-init, as it’s confusing to use a goto to skip over an initialization. Fix the few places in the code that run afoul of this warning. * configure.ac (WERROR_CFLAGS): Add -Wjump-misses-init. * src/doc.c (Fsubstitute_command_keys): * src/image.c (svg_load_image): * src/regex.c (re_match_2_internal): * src/xdisp.c (redisplay_internal, redisplay_window): Don’t jump over initialization.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1cbd297f5e7..e750a438165 100644
--- a/configure.ac
+++ b/configure.ac
@@ -911,7 +911,6 @@ else
nw="$nw -Wvla" # Emacs uses <vla.h>.
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Winline" # OK to ignore 'inline'
- nw="$nw -Wjump-misses-init" # We sometimes safely jump over init.
nw="$nw -Wstrict-overflow" # OK to optimize assuming that
# signed overflow has undefined behavior
nw="$nw -Wsync-nand" # irrelevant here, and provokes ObjC warning