summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarol Ostrovsky <karol.ostrovsky@gmail.com>2014-08-23 11:48:30 +0300
committerEli Zaretskii <eliz@gnu.org>2014-08-23 11:48:30 +0300
commit0d880e737bea413b8dd2068f7c4110950929271a (patch)
tree84aded133325f8b364a1374051eecad62adf161f /configure.ac
parent30f1ca3b9ac0f0e7a997e98829fd7c423f1334d0 (diff)
downloademacs-0d880e737bea413b8dd2068f7c4110950929271a.tar.gz
Fix bug #18302 with minor issues in the MSYS2/MinGW64 build.
configure.ac: Accept "*-mingw*", not just "*-mingw32", as canonical name of a MinGW build, because using MSYS2 'uname' produces "MINGW64". src/Makefile.in (emacs$(EXEEXT)): Retry deletion of bootstrap-emacs if the initial "rm -f" fails. This is for MinGW builds, where MS-Windows will not allow deleting the executable file of a running program.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 806b1b4f308..ef7506e726d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -650,7 +650,7 @@ case "${canonical}" in
i[3456]86-*-* )
case "${canonical}" in
*-darwin* ) opsys=darwin ;;
- *-mingw32 )
+ *-mingw* )
opsys=mingw32
# MinGW overrides and adds some system headers in nt/inc.
GCC_TEST_OPTIONS="-I $srcdir/nt/inc"
@@ -665,7 +665,7 @@ case "${canonical}" in
# MinGW64
x86_64-*-* )
case "${canonical}" in
- *-mingw32 )
+ *-mingw* )
opsys=mingw32
# MinGW overrides and adds some system headers in nt/inc.
GCC_TEST_OPTIONS="-I $srcdir/nt/inc"
@@ -1323,7 +1323,7 @@ test "$opsys" = "aix4.2" && test "x$GCC" != "xyes" && \
C_SWITCH_SYSTEM="-ma -qmaxmem=4000"
if test "$opsys" = "mingw32"; then
case "$canonical" in
- x86_64-*-mingw32) C_SWITCH_SYSTEM="-mtune=generic" ;;
+ x86_64-*-mingw*) C_SWITCH_SYSTEM="-mtune=generic" ;;
*) C_SWITCH_SYSTEM="-mtune=pentium4" ;;
esac
fi