summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2013-09-05 11:33:03 +0300
committerEli Zaretskii <eliz@gnu.org>2013-09-05 11:33:03 +0300
commit50a5f95ec5e610e8edbe09b03388c83684d87fd7 (patch)
tree5444c58409120e482b06b3053ae317cf8c798dd3 /configure.ac
parent41306318777a942420bc4feadbfacf662ea179dc (diff)
downloademacs-50a5f95ec5e610e8edbe09b03388c83684d87fd7.tar.gz
Made HAVE_MENUS the default; comment fix in term.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index cfec49e5645..1e650105244 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1836,11 +1836,8 @@ to configure.])
fi
fi
-### If we're using X11, we should use the X menu package.
-HAVE_MENUS=no
-case ${HAVE_X11} in
- yes ) HAVE_MENUS=yes ;;
-esac
+### We always support menus.
+HAVE_MENUS=yes
# Does the opsystem file prohibit the use of the GNU malloc?
# Assume not, until told otherwise.
@@ -3122,15 +3119,9 @@ if test "${HAVE_NS}" = "yes"; then
## Extra CFLAGS applied to src/*.m files.
GNU_OBJC_CFLAGS="$GNU_OBJC_CFLAGS -fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE"
fi
- # We also have mouse menus.
- HAVE_MENUS=yes
OTHER_FILES=ns-app
fi
-if test "${HAVE_W32}" = "yes"; then
- HAVE_MENUS=yes
-fi
-
### Use session management (-lSM -lICE) if available
HAVE_X_SM=no
LIBXSM=
@@ -4609,9 +4600,7 @@ AC_SUBST(OLDXMENU_DEPS)
if test "${HAVE_MENUS}" = "yes" ; then
AC_DEFINE(HAVE_MENUS, 1,
- [Define to 1 if you have mouse menus.
- (This is automatic if you use X, but the option to specify it remains.)
- It is also defined with other window systems that support xmenu.c.])
+ [Define to 1 if you have mouse menus. (This is supported in all configurations, but the option to specify it remains.)])
fi
if test "${GNU_MALLOC}" = "yes" ; then