summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-02-01 11:39:36 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2015-02-01 11:45:15 -0800
commit241260cc2819e5df254ad85953588b06388ade61 (patch)
tree3b0099a54471738d76567ff650466a14cd3de954 /configure.ac
parent1d1162479caf1fdf48564f1486fa84e3cdacaa9b (diff)
downloademacs-241260cc2819e5df254ad85953588b06388ade61.tar.gz
Revert changes installed by xwidgets merge
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 1 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index a679bd0a240..5776e4ef8ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -374,8 +374,6 @@ otherwise for the first of `gfile' or `inotify' that is usable.])
],
[with_file_notification=$with_features])
-OPTION_DEFAULT_OFF([xwidgets],[enable use of some gtk widgets in Emacs buffers])
-
## For the times when you want to build Emacs but don't have
## a suitable makeinfo, and can live without the manuals.
dnl http://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01844.html
@@ -2529,41 +2527,6 @@ if test "${HAVE_GTK}" = "yes"; then
term_header=gtkutil.h
fi
-
-HAVE_XWIDGETS=no
-HAVE_WEBKIT=no
-HAVE_GIR=no
-
-if test "${with_xwidgets}" != "no" && test "${USE_GTK_TOOLKIT}" = "GTK3" && test "$window_system" != "none" ; then
- echo "xwidgets enabled, checking webkit, and others"
- HAVE_XWIDGETS=yes
- AC_DEFINE(HAVE_XWIDGETS, 1, [Define to 1 if you have xwidgets support.])
-dnl xwidgets
-dnl - enable only if GTK3 is enabled, and we have a window system
-dnl - check for webkit and gobject introspection
-
-
-#webkit version for gtk3.
- WEBKIT_REQUIRED=1.4.0
- WEBKIT_MODULES="webkitgtk-3.0 >= $WEBKIT_REQUIRED"
-
- if test "${with_gtk3}" = "yes"; then
- PKG_CHECK_MODULES(WEBKIT, $WEBKIT_MODULES, HAVE_WEBKIT=yes, HAVE_WEBKIT=no)
- if test $HAVE_WEBKIT = yes; then
- AC_DEFINE(HAVE_WEBKIT_OSR, 1, [Define to 1 if you have webkit_osr support.])
- fi
- fi
-
- GIR_REQUIRED=1.32.1
- GIR_MODULES="gobject-introspection-1.0 >= $GIR_REQUIRED"
- PKG_CHECK_MODULES(GIR, $GIR_MODULES, HAVE_GIR=yes, HAVE_GIR=no)
- if test $HAVE_GIR = yes; then
- AC_DEFINE(HAVE_GIR, 1, [Define to 1 if you have GIR support.])
- fi
-
-
-fi
-
CFLAGS=$OLD_CFLAGS
LIBS=$OLD_LIBS
@@ -4843,7 +4806,7 @@ TOOLKIT_LIBW=
case "$USE_X_TOOLKIT" in
MOTIF) TOOLKIT_LIBW="$MOTIF_LIBW" ;;
LUCID) TOOLKIT_LIBW="$LUCID_LIBW" ;;
- none) test "x$HAVE_GTK" = "xyes" && TOOLKIT_LIBW="$GTK_LIBS -lXcomposite" ;;
+ none) test "x$HAVE_GTK" = "xyes" && TOOLKIT_LIBW="$GTK_LIBS" ;;
esac
AC_SUBST(TOOLKIT_LIBW)
@@ -5164,10 +5127,6 @@ echo " Does Emacs use -lxft? ${HAVE_XFT}"
echo " Does Emacs directly use zlib? ${HAVE_ZLIB}"
echo " Does Emacs use toolkit scroll bars? ${USE_TOOLKIT_SCROLL_BARS}"
-
-echo " Does Emacs support Xwidgets? ${HAVE_XWIDGETS}"
-echo " Does xwidgets support webkit(requires gtk3)? ${HAVE_WEBKIT}"
-echo " Does xwidgets support gobject introspection? ${HAVE_GIR}"
echo
if test -n "${EMACSDATA}"; then