summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2015-01-20 18:26:28 +0200
committerEli Zaretskii <eliz@gnu.org>2015-01-20 18:26:28 +0200
commit3ee38f2000944d50adb2c65bd1af11c464c87950 (patch)
tree283e49344070f500839df4efb3c413bff19141e6 /configure.ac
parente6518fc8f5afca5d71582aabb089147cba583966 (diff)
downloademacs-3ee38f2000944d50adb2c65bd1af11c464c87950.tar.gz
Disallow w32 builds --without-toolkit-scroll-bars.
configure.ac (HAVE_W32): Abort with error message if --without-toolkit-scroll-bars was specified. See http://lists.gnu.org/archive/html/emacs-devel/2015-01/msg00525.html for the details.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bae020e7338..9c8df9dcdb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1841,6 +1841,9 @@ CM_OBJ="cm.o"
XARGS_LIMIT=
if test "${HAVE_W32}" = "yes"; then
AC_DEFINE(HAVE_NTGUI, 1, [Define to use native MS Windows GUI.])
+ if test "$with_toolkit_scroll_bars" = "no"; then
+ AC_MSG_ERROR([Non-toolkit scroll bars are not implemented for w32 build.])
+ fi
AC_CHECK_TOOL(WINDRES, [windres],
[AC_MSG_ERROR([No resource compiler found.])])
W32_OBJ="w32fns.o w32menu.o w32reg.o w32font.o w32term.o"