summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Antipov <dmantipov@yandex.ru>2012-08-08 20:17:15 +0400
committerDmitry Antipov <dmantipov@yandex.ru>2012-08-08 20:17:15 +0400
commitda3d210583cd7a9a22ca6a2d07cac5bbf6fca7c1 (patch)
treeadcc9e05f2b84c5f48607025c67894fb0f9f38cd /configure.ac
parent128a5c0d89c37958171f09558a79440bdcd564b7 (diff)
downloademacs-da3d210583cd7a9a22ca6a2d07cac5bbf6fca7c1.tar.gz
Fix and document recently introduced configuration options.
* configure.ac (--disable-features): Rename to --without-all. (OPTION_DEFAULT_ON): Change to use with_features. * INSTALL: Fix description. * etc/NEWS: Mention --without-all and --enable-link-time-optimization.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3fbea8c80ea..51dd8a375ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,13 +48,13 @@ archlibdir='${libexecdir}/emacs/${version}/${configuration}'
docdir='${datadir}/emacs/${version}/etc'
gamedir='${localstatedir}/games/emacs'
-dnl Do not omit a lot of the nice features by default.
-AC_ARG_ENABLE(features,
-[AS_HELP_STRING([--disable-features],
+dnl Special option to disable the most of other options.
+AC_ARG_WITH(all,
+[AS_HELP_STRING([--without-all],
[omit almost all features and build
small executable with minimal dependencies])],
- enable_features=$enableval,
- enable_features=yes)
+ with_features=$withval,
+ with_features=yes)
dnl OPTION_DEFAULT_OFF(NAME, HELP-STRING)
dnl Create a new --with option that defaults to being disabled.
@@ -80,7 +80,7 @@ dnl non-alphanumeric characters with "_".
dnl HELP-STRING is the help text for the option.
AC_DEFUN([OPTION_DEFAULT_ON], [dnl
AC_ARG_WITH([$1],[AS_HELP_STRING([--without-$1],[$2])],[],[dnl
- m4_bpatsubst([with_$1], [[^0-9a-z]], [_])=$enable_features])dnl
+ m4_bpatsubst([with_$1], [[^0-9a-z]], [_])=$with_features])dnl
])dnl
OPTION_DEFAULT_ON([pop],[don't support POP mail retrieval with movemail])