summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2010-05-29 11:54:16 -0700
committerGlenn Morris <rgm@gnu.org>2010-05-29 11:54:16 -0700
commit8cce271eac68fef59d37c95b28784693c26e55e9 (patch)
tree033dbd205787928bae84e30be4b087edacedef8a /configure.in
parentbc8d33d540d079af28ea93a0cf8df829911044ca (diff)
downloademacs-8cce271eac68fef59d37c95b28784693c26e55e9.tar.gz
Add some comments related to how epaths.h gets built.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5ceb2c3bd48..9694a91739f 100644
--- a/configure.in
+++ b/configure.in
@@ -32,6 +32,10 @@ dnl Support for --program-prefix, --program-suffix and
dnl --program-transform-name options
AC_ARG_PROGRAM
+dnl It is important that variables on the RHS not be expanded here,
+dnl hence the single quotes. This is per the GNU coding standards, see
+dnl (autoconf) Installation Directory Variables
+dnl See also epaths.h below.
lispdir='${datadir}/emacs/${version}/lisp'
locallisppath='${datadir}/emacs/${version}/site-lisp:'\
'${datadir}/emacs/site-lisp'
@@ -3750,6 +3754,14 @@ fi
test "${exec_prefix}" != NONE &&
exec_prefix=`echo "${exec_prefix}" | sed 's,\([^/]\)/*$,\1,'`]
+dnl You might wonder (I did) why epaths.h is generated by running make,
+dnl rather than just letting configure generate it from epaths.in.
+dnl One reason is that the various paths are not fully expanded (see above);
+dnl eg gamedir=${prefix}/var/games/emacs.
+dnl Secondly, the GNU Coding standards require that one should be able
+dnl to run `make prefix=/some/where/else' and override the values set
+dnl by configure. This also explains the `move-if-change' test and
+dnl the use of force in the `epaths-force' rule in Makefile.in.
AC_OUTPUT(Makefile lib-src/Makefile oldXMenu/Makefile \
doc/emacs/Makefile doc/misc/Makefile doc/lispintro/Makefile \
doc/lispref/Makefile src/Makefile \