summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2010-05-16 16:01:56 -0700
committerGlenn Morris <rgm@gnu.org>2010-05-16 16:01:56 -0700
commitb02a664581bd689ab006de403b1ef357a814f495 (patch)
tree7105f25de296929dc545cf16adeb8b9dd9cf09b9 /configure.in
parent8877ca0fdc090b6506a95272c0e6f1e16c3b0571 (diff)
downloademacs-b02a664581bd689ab006de403b1ef357a814f495.tar.gz
Simplify temacs build rule.
* configure.in (TEMACS_LDFLAGS2): New output variable. * configure: Regenerate. * msdos/sed1v2.inp (TEMACS_LDFLAGS2): Edit to $(LDFLAGS). * src/Makefile.in (TEMACS_LDFLAGS2): New, set by configure. (temacs${EXEEXT}): Combine the NS_IMPL_GNUSTEP case with the default.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 15214aa359b..28846991ae5 100644
--- a/configure.in
+++ b/configure.in
@@ -1458,6 +1458,7 @@ tmp_CPPFLAGS="$CPPFLAGS"
tmp_CFLAGS="$CFLAGS"
CPPFLAGS="$CPPFLAGS -x objective-c"
CFLAGS="$CFLAGS -x objective-c"
+TEMACS_LDFLAGS2="\${LDFLAGS}"
if test "${with_ns}" != no; then
if test "${opsys}" = darwin; then
NS_IMPL_COCOA=yes
@@ -1490,6 +1491,7 @@ shared=no
LDFLAGS="$LDFLAGS -L${GNUSTEP_SYSTEM_LIBRARIES}"
LIB_STANDARD=
START_FILES=
+ TEMACS_LDFLAGS2=
fi
AC_CHECK_HEADER([AppKit/AppKit.h], [HAVE_NS=yes],
[AC_MSG_ERROR([`--with-ns' was specified, but the include
@@ -1505,6 +1507,7 @@ shared=no
fi
AC_SUBST(NS_IMPL_GNUSTEP_INC)
AC_SUBST(NS_IMPL_GNUSTEP_TEMACS_LDFLAGS)
+AC_SUBST(TEMACS_LDFLAGS2)
NS_OBJ=
NS_SUPPORT=