summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1998-12-16 21:13:48 +0000
committerKarl Heuer <kwzh@gnu.org>1998-12-16 21:13:48 +0000
commite786c0694b23f07f00ab3755557ec45166d907f0 (patch)
tree8a57c13478e0a8689a9160016c04dafdad029cbd /configure.in
parenta2faecac7767ea9a02fed7b1907f4cceff7c341c (diff)
downloademacs-e786c0694b23f07f00ab3755557ec45166d907f0.tar.gz
Remove GSS-API support, since it has been removed from movemail.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 7da558b12cd..748115eabf4 100644
--- a/configure.in
+++ b/configure.in
@@ -54,9 +54,6 @@ AC_DEFINE(KERBEROS5)])
AC_ARG_WITH(hesiod,
[ --with-hesiod support Hesiod to get the POP server host],
[AC_DEFINE(HESIOD)])
-AC_ARG_WITH(gssapi,
-[ --with-gssapi support GSSAPI-authenticated POP],
-[AC_DEFINE(GSSAPI)])
dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
dnl keep them together visually.
@@ -1639,11 +1636,7 @@ if test "${with_kerberos+set}" = set; then
AC_CHECK_LIB(com_err, com_err)
AC_CHECK_LIB(crypto, mit_des_cbc_encrypt)
AC_CHECK_LIB(krb5, krb5_init_context)
- if test "${with_kerberos5+set}" = set; then
- if test "${with_gssapi+set}" = set; then
- AC_CHECK_LIB(gssapi_krb5,gss_init_sec_context)
- fi
- else
+ if test "${with_kerberos5+set}" != set; then
AC_CHECK_LIB(des, des_cbc_encrypt,,
AC_CHECK_LIB(des425, des_cbc_encrypt))
AC_CHECK_LIB(krb, krb_get_cred,,
@@ -1663,11 +1656,6 @@ if test "${with_kerberos+set}" = set; then
AC_CHECK_HEADERS(com_err.h)
fi
-if test "${with_gssapi+set}" = set; then
- AC_CHECK_LIB(gssapi, gss_init_sec_context)
- AC_CHECK_HEADERS(gssapi.h)
-fi
-
# Solaris requires -lintl if you want strerror (which calls dgettext)
# to return localized messages.
AC_CHECK_LIB(intl, dgettext)