summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2011-06-21 10:10:10 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2011-06-21 10:10:10 -0700
commite92b6c884116d70e224e9cb535ed85a2b05665a5 (patch)
tree326b1a79ec5657e8deddc5baaeb5b5e5b8879104 /configure.in
parent8462fc0ce20cc1caf883996d193d1cd2c1629498 (diff)
downloademacs-e92b6c884116d70e224e9cb535ed85a2b05665a5.tar.gz
* configure.in: Port alloca to AIX 3.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index e4d2e2e96c8..fdeae8e6152 100644
--- a/configure.in
+++ b/configure.in
@@ -2678,14 +2678,6 @@ gl_ASSERT_NO_GNULIB_POSIXCHECK
gl_ASSERT_NO_GNULIB_TESTS
gl_INIT
-# Check for alloca.
-dnl src/alloca.c has been removed. Could also check if $ALLOCA is set?
-dnl FIXME is there an autoconf test that does the right thing, without
-dnl needing to call A_M_E afterwards?
-if test x"$ac_cv_func_alloca_works" != xyes; then
- AC_MSG_ERROR( [a system implementation of alloca is required] )
-fi
-
# UNIX98 PTYs.
AC_CHECK_FUNCS(grantpt)
@@ -3458,6 +3450,12 @@ along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>. */
])dnl
AH_BOTTOM([
+/* On AIX 3 this must be included before any other include file. */
+#include <alloca.h>
+#if ! HAVE_ALLOCA
+# error "alloca not available on this machine"
+#endif
+
/* Define AMPERSAND_FULL_NAME if you use the convention
that & in the full name stands for the login id. */
/* Turned on June 1996 supposing nobody will mind it. */
@@ -3533,7 +3531,6 @@ AH_BOTTOM([
#include <string.h>
#include <stdlib.h>
-#include <alloca.h>
#ifndef HAVE_STRCHR
#define strchr(a, b) index (a, b)