summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2010-07-07 20:31:04 -0700
committerDan Nicolaescu <dann@ics.uci.edu>2010-07-07 20:31:04 -0700
commit49d9e6b07bc34acf755ded0fc255e974a37f9189 (patch)
tree5646f202d13f595532e744b675e4a2f0201f810d /configure.in
parent313d9eb21863418cb91328c3d5ef0c2d356fc483 (diff)
downloademacs-49d9e6b07bc34acf755ded0fc255e974a37f9189.tar.gz
Remove src/prefix-args.c.
* configure.in (PRE_EDIT_LDFLAGS, POST_EDIT_LDFLAGS): Remove. * msdos/sed1v2.inp: Remove reference to prefix-args. * prefix-args.c: Remove file. * src/autodeps.mk (ALLOBJS): Remove reference to prefix-args. * src/Makefile.in (temacs${EXEEXT}): Remove references to PRE_EDIT_LDFLAGS and POST_EDIT_LDFLAGS. (mostlyclean): Remove reference to prefix-args. (prefix-args): Remove.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 373cc799d0b..a91d3c7b6ac 100644
--- a/configure.in
+++ b/configure.in
@@ -3360,8 +3360,6 @@ case "$opsys" in
esac
-PRE_EDIT_LDFLAGS=
-POST_EDIT_LDFLAGS=
if test "x$ORDINARY_LINK" = "xyes"; then
LINKER="\$(CC)"
@@ -3380,17 +3378,7 @@ elif test "x$GCC" = "xyes" && test "x$LINKER" = "x"; then
## searching for libraries in its internal directories, so we have to
## ask GCC explicitly where to find libgcc.a (LIB_GCC below).
LINKER="\$(CC) -nostdlib"
- ## GCC passes any argument prefixed with -Xlinker directly to the linker.
- ## See prefix-args.c for an explanation of why we do not do this with the
- ## shell''s ``for'' construct. Note that sane people do not have '.' in
- ## their paths, so we must use ./prefix-args.
- ## TODO either make prefix-args check ORDINARY_LINK internally,
- ## or remove it altogether (bug#6184), removing the need for this hack.
- PRE_EDIT_LDFLAGS='`./prefix-args -Xlinker'
- POST_EDIT_LDFLAGS='`'
-fi
-AC_SUBST(PRE_EDIT_LDFLAGS)
-AC_SUBST(POST_EDIT_LDFLAGS)
+fi
test "x$LINKER" = "x" && LINKER=ld
## FIXME? What setting of EDIT_LDFLAGS should this have?