summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKenichi Handa <handa@m17n.org>2005-05-11 12:16:42 +0000
committerKenichi Handa <handa@m17n.org>2005-05-11 12:16:42 +0000
commita9b84515eda652c1c28664e6466ecb25cc7a9600 (patch)
treec29530d29d2b0564b1ff727d85ec5ae16270ba9a /configure.in
parent4c452d71b683d94c6f989a7dab957eab943f2b12 (diff)
downloademacs-a9b84515eda652c1c28664e6466ecb25cc7a9600.tar.gz
While running cpp on junk.c, include
-DHAVE_UNIDATA in CPPFLAGS if admin/unidata/UnicodeData.txt exists.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e384ed68b5d..136cd510307 100644
--- a/configure.in
+++ b/configure.in
@@ -3179,6 +3179,9 @@ echo creating src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
< Makefile.c > junk.c
+ if test -f ${srcdir}/admin/unidata/UnicodeData.txt; then
+ CPPFLAGS="$CPPFLAGS -DHAVE_UNIDATA"
+ fi
$CPP $undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new