summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKenichi Handa <handa@m17n.org>2008-10-30 07:11:41 +0000
committerKenichi Handa <handa@m17n.org>2008-10-30 07:11:41 +0000
commit28f3a9d1fe4afc26604ccd85ac3fb74b514950e6 (patch)
tree93c16a64cdffcf123c392026c38687a0b182fe57 /configure.in
parent35f0040952d79218e213c2e1d224c2b46fe2e0dc (diff)
downloademacs-28f3a9d1fe4afc26604ccd85ac3fb74b514950e6.tar.gz
Check fontconfig always.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 3ec853bfba2..e40203bb38c 100644
--- a/configure.in
+++ b/configure.in
@@ -1825,6 +1825,8 @@ either XPointer or XPointer*.])dnl
fi
### Start of font-backend section.
+PKG_CHECK_MODULES(FONTCONFIG, fontconfig >= 2.2.0, HAVE_FC=yes, HAVE_FC=no)
+test "${HAVE_FC}" = "no" && with_freetype=no
## Use -lXft if available, unless `--with-freetype=no' nor `--with-xft=no'.
HAVE_XFT=maybe
@@ -1868,16 +1870,11 @@ if test "${HAVE_XFT}" = "yes"; then
dnl As we use Xft, we anyway use freetype.
dnl In this case, there's no need of additional CFLAGS and LIBS.
HAVE_FREETYPE=yes
+ FONTCONFIG_CFLAGS=
+ FONTCONFIG_LIBS=
elif test "x${with_freetype}" != "xno" && test "x${with_x}" != "xno"; then
PKG_CHECK_MODULES(FREETYPE, freetype2, HAVE_FREETYPE=yes, HAVE_FREETYPE=no)
- if test "${HAVE_FREETYPE}" = "yes"; then
- PKG_CHECK_MODULES(FONTCONFIG, fontconfig, HAVE_FC=yes, HAVE_FC=no)
- if test "${HAVE_FC}" = "no"; then
- dnl Without fontconfig, we can't use freetype at the moment.
- HAVE_FREETYPE=no
- fi
- fi
fi
HAVE_LIBOTF=no