summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-09-01 14:05:06 +0000
committerGerd Moellmann <gerd@gnu.org>2000-09-01 14:05:06 +0000
commit1890c0c425de528d5c2c6373fa51e9876d63ca5d (patch)
tree38ad7a24c42d201501f9a33f39e76a6ecf26c277 /configure.in
parentf72adc12d5669d5cc64ff6539dc36e74afefb79d (diff)
downloademacs-1890c0c425de528d5c2c6373fa51e9876d63ca5d.tar.gz
Add ``checking'' messages for
XpmReturnAllocPixels.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f2be12849a2..28c1e7f69d8 100644
--- a/configure.in
+++ b/configure.in
@@ -1778,6 +1778,7 @@ if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/xpm.h,
AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
if test "${HAVE_XPM}" = "yes"; then
+ AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
AC_EGREP_CPP(no_return_alloc_pixels,
[#include "X11/xpm.h"
#ifndef XpmReturnAllocPixels
@@ -1786,6 +1787,11 @@ no_return_alloc_pixels
], HAVE_XPM=no, HAVE_XPM=yes)
fi
CFLAGS="${old_c_flags}"
+ if test "${HAVE_XPM}" = "yes"; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
fi
if test "${HAVE_XPM}" = "yes"; then