summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-07-08 13:03:56 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-07-08 13:03:56 -0700
commit0ccb0b098349c987e35ee1b2ec795f24a743a4e0 (patch)
tree2c55a484b6141b0e375bca7160cf2635fe01719d /configure.in
parent3434fe8a236bb8fcb098c713b6383810c16a721d (diff)
downloademacs-0ccb0b098349c987e35ee1b2ec795f24a743a4e0.tar.gz
Restore deprecation warnings, except for older libpng.
* configure.in (WARN_CFLAGS): Remove -Wno-deprecated-declarations. (HAVE_LIBPNG_PNG_H): Don't bother checking for this if we have png.h. (PNG_DEPRECATED): Define when compiling with older PNG versions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6a90c4869e5..4df12844b1d 100644
--- a/configure.in
+++ b/configure.in
@@ -697,7 +697,6 @@ else
gl_WARN_ADD([-Wno-switch]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-format-nonliteral])
- gl_WARN_ADD([-Wno-deprecated-declarations]) # triggered by libpng
# In spite of excluding -Wlogical-op above, it is enabled, as of
# gcc 4.5.0 20090517.
@@ -2451,7 +2450,7 @@ if test "${HAVE_X11}" = "yes"; then
if test "${with_png}" != "no"; then
# Debian unstable as of July 2003 has multiple libpngs, and puts png.h
# in /usr/include/libpng.
- AC_CHECK_HEADERS(png.h libpng/png.h)
+ AC_CHECK_HEADERS(png.h libpng/png.h, break)
if test "$ac_cv_header_png_h" = yes || test "$ac_cv_header_libpng_png_h" = yes ; then
AC_CHECK_LIB(png, png_get_channels, HAVE_PNG=yes, , -lz -lm)
fi
@@ -2460,6 +2459,19 @@ if test "${HAVE_X11}" = "yes"; then
if test "${HAVE_PNG}" = "yes"; then
AC_DEFINE(HAVE_PNG, 1, [Define to 1 if you have the png library (-lpng).])
LIBPNG="-lpng -lz -lm"
+
+ AC_CHECK_DECL(png_longjmp,
+ [],
+ [AC_DEFINE(PNG_DEPRECATED, [],
+ [Define to empty to suppress deprecation warnings when building
+ with --enable-gcc-warnings and with libpng versions before 1.5,
+ which lack png_longjmp.])],
+ [[#ifdef HAVE_LIBPNG_PNG_H
+ # include <libpng/png.h>
+ #else
+ # include <png.h>
+ #endif
+ ]])
fi
fi
AC_SUBST(LIBPNG)