summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-06-12 13:43:09 -0400
committerGlenn Morris <rgm@gnu.org>2012-06-12 13:43:09 -0400
commit45fa9c0fbf53ff12f78991698ec996737072d66e (patch)
tree36504687d23b4442c44c667a7420b8c079f21b87 /configure.in
parent03043c1b27476919e6327e3c18d6e6c2b6c70631 (diff)
downloademacs-45fa9c0fbf53ff12f78991698ec996737072d66e.tar.gz
Move NO_TERMIO, BROKEN_SIGIO from src/s to configure
* configure.in (NO_TERMIO, BROKEN_SIGIO): New AC_DEFINEs. * src/s/bsd-common.h, src/s/darwin.h, src/s/gnu-kfreebsd.h, src/s/hpux10-20.h: Remove NO_TERMIO. * src/s/hpux10-20.h, src/s/openbsd.h, src/s/usg5-4-common.h: Remove BROKEN_SIGIO.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ba3e184579..2750ccdcd54 100644
--- a/configure.in
+++ b/configure.in
@@ -3111,6 +3111,20 @@ dnl and macros for terminal control.])
dnl AC_DEFINE(HAVE_TCATTR, 1, [Define to 1 if you have tcgetattr and tcsetattr.])
dnl fi
+case $opsys in
+ darwin | gnu | hpux* | *bsd )
+ AC_DEFINE(NO_TERMIO, 1, [Define if termio.h should not be included.])
+ ;;
+esac
+
+dnl SIGIO exists, but the feature doesn't work in the way Emacs needs.
+dnl See eg <http://article.gmane.org/gmane.os.openbsd.ports/46831>.
+case $opsys in
+ hpux* | irix6-5 | openbsd | sol2* | unixware )
+ AC_DEFINE(BROKEN_SIGIO, 1, [Define if SIGIO should not be used.])
+ ;;
+esac
+
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"
CPPFLAGS="$REAL_CPPFLAGS"