summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2012-06-23 11:55:13 +0200
committerAndreas Schwab <schwab@linux-m68k.org>2012-06-23 11:55:13 +0200
commit54e8a4185fdfac1dddf1712206cdf232fd5f03f2 (patch)
treee6405911021b9c14a2b288c412562d4ec0d5f107 /configure.in
parente8a022046f57aa23f605593e0ccd901da1776c5e (diff)
downloademacs-54e8a4185fdfac1dddf1712206cdf232fd5f03f2.tar.gz
* configure.in: Don't use AC_CHECK_FUNCS_ONCE, which doesn't use
the correct CFLAGS and LIBS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index cbd52b13b0b..4c3316a0d3b 100644
--- a/configure.in
+++ b/configure.in
@@ -2660,7 +2660,7 @@ esac
AC_SUBST(BLESSMAIL_TARGET)
-AC_CHECK_FUNCS_ONCE(gethostname \
+AC_CHECK_FUNCS(gethostname \
rename closedir mkdir rmdir getrusage get_current_dir_name \
random lrand48 logb frexp fmod rint cbrt setsid \
strerror fpathconf select euidaccess getpagesize setlocale \
@@ -2691,10 +2691,10 @@ AC_FUNC_FSEEKO
AC_FUNC_GETPGRP
# UNIX98 PTYs.
-AC_CHECK_FUNCS_ONCE(grantpt)
+AC_CHECK_FUNCS(grantpt)
# PTY-related GNU extensions.
-AC_CHECK_FUNCS_ONCE(getpt)
+AC_CHECK_FUNCS(getpt)
# Check this now, so that we will NOT find the above functions in ncurses.
# That is because we have not set up to link ncurses in lib-src.
@@ -2951,7 +2951,7 @@ AC_SUBST(KRB5LIB)
AC_SUBST(DESLIB)
AC_SUBST(KRB4LIB)
-AC_CHECK_FUNCS_ONCE(tzset)
+AC_CHECK_FUNCS(tzset)
AC_MSG_CHECKING(whether localtime caches TZ)
AC_CACHE_VAL(emacs_cv_localtime_cache,
[if test x$ac_cv_func_tzset = xyes; then
@@ -3018,7 +3018,7 @@ fi
AC_FUNC_FORK
-AC_CHECK_FUNCS_ONCE(snprintf)
+AC_CHECK_FUNCS(snprintf)
dnl Adapted from Haible's version.
AC_CACHE_CHECK([for nl_langinfo and CODESET], emacs_cv_langinfo_codeset,