summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2011-07-06 16:34:39 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2011-07-06 16:34:39 -0700
commit59361254a6ea5fcfc2f1ec344665aa719fbb936f (patch)
tree6471eaf76563f8b2f7aab90bf07ff0dd73470599 /configure.in
parent9cfdb3ec08672f13088ebd133bbc794c04a66b05 (diff)
parent8a5c77bba5e38c62605f0f053670a7955130fcc7 (diff)
downloademacs-59361254a6ea5fcfc2f1ec344665aa719fbb936f.tar.gz
Merge from trunk.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f23493811fa..e8a0b56d268 100644
--- a/configure.in
+++ b/configure.in
@@ -1996,13 +1996,13 @@ fi
dnl GConf has been tested under GNU/Linux only.
dnl The version is really arbitrary, it is about the same age as Gtk+ 2.6.
HAVE_GCONF=no
-if test "${HAVE_GSETTINGS}" = "no" && test "${HAVE_X11}" = "yes" && test "${with_gconf}" = "yes"; then
+if test "${HAVE_X11}" = "yes" && test "${with_gconf}" = "yes"; then
PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.13, HAVE_GCONF=yes, HAVE_GCONF=no)
if test "$HAVE_GCONF" = yes; then
AC_DEFINE(HAVE_GCONF, 1, [Define to 1 if using GConf.])
dnl Newer GConf doesn't link with g_objects, so this is not defined.
- SETTINGS_CFLAGS="$GCONF_CFLAGS"
- SETTINGS_LIBS="$GCONF_LIBS"
+ SETTINGS_CFLAGS="$SETTINGS_CFLAGS $GCONF_CFLAGS"
+ SETTINGS_LIBS="$SETTINGS_LIBS $GCONF_LIBS"
fi
fi