summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2010-07-02 01:11:24 -0700
committerDan Nicolaescu <dann@ics.uci.edu>2010-07-02 01:11:24 -0700
commitd9170db5208a86d94a6d8a89c8fa1e678bd094bd (patch)
treef15dc1b36d3807346f6f346b1c229e53a6a72ca4 /configure.in
parent986011195e5c40b9644c21da166c12cb34176350 (diff)
downloademacs-d9170db5208a86d94a6d8a89c8fa1e678bd094bd.tar.gz
Define USE_LISP_UNION_TYPE using autoconf.
* configure.in (--enable-use-lisp-union-type): New flag. * src/lisp.h: Document that USE_LISP_UNION_TYPE is now enabled using autoconf.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 97e2adc753c..b04bf6ea744 100644
--- a/configure.in
+++ b/configure.in
@@ -305,6 +305,16 @@ if test x$ac_gc_check_cons_list != x ; then
[Define this to check for errors in cons list.])
fi
+AC_ARG_ENABLE(use-lisp-union-type,
+[AS_HELP_STRING([--enable-use-lisp-union-type],
+ [use a union for the Lisp_Object data type.
+ This is only useful for development for catching certain types of bugs.])],
+if test "${enableval}" != "no"; then
+ AC_DEFINE(USE_LISP_UNION_TYPE, 1,
+ [Define this to use a lisp union for the Lisp_Object data type.])
+fi)
+
+
AC_ARG_ENABLE(profiling,
[AS_HELP_STRING([--enable-profiling],
[build emacs with profiling support.