summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <dann@ics.uci.edu>2010-06-29 22:51:07 -0700
committerDan Nicolaescu <dann@ics.uci.edu>2010-06-29 22:51:07 -0700
commitf71cd38ac42420fc0c7290e0adedf965749d74df (patch)
tree14c22a29d15818874958fd9523a4e3f463eee7ed /configure.in
parentf4981b7e31e98ed2f2d46733961c5ca211cc41c4 (diff)
downloademacs-f71cd38ac42420fc0c7290e0adedf965749d74df.tar.gz
Fix CFLAGS for non-GCC compilers.
* configure.in (CFLAGS): Always use -g like it was done before the 2010-03-30 change. (REAL_CFLAGS): Use CFLAGS for non-GCC to get optimization flags. (Bug#6538)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index bb2866b6654..805ea9c4134 100644
--- a/configure.in
+++ b/configure.in
@@ -847,23 +847,19 @@ CPP=`eval "echo $CPP"`
### First figure out CFLAGS (which we use for running the compiler here)
### and REAL_CFLAGS (which we use for real compilation).
-### The two are the same except on a few systems, where they are made
-### different to work around various lossages. For example,
-### GCC 2.5 on GNU/Linux needs them to be different because it treats -g
-### as implying static linking.
+### The two are the same except when using GCC where we might use
+### extra warning and profiling flags.
### If the CFLAGS env var is specified, we use that value
### instead of the default.
-dnl C_OPTIMIZE_SWITCH unused save for gcc, so why set it for non-gcc?
dnl Note AC_PROG_CC sets CFLAGS to -g -O2 for gcc anyway.
if test "x$SPECIFIED_CFLAGS" = x; then
+ CFLAGS="-g $C_OPTIMIZE_SWITCH"
if test x$GCC = xyes; then
- CFLAGS="-g $C_OPTIMIZE_SWITCH"
REAL_CFLAGS="$CFLAGS $C_WARNINGS_SWITCH $PROFILING_CFLAGS"
else
- CFLAGS=
- REAL_CFLAGS=
+ REAL_CFLAGS="$CFLAGS"
fi
else
REAL_CFLAGS="$CFLAGS"