summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <gerd@gnu.org>2000-07-10 20:37:48 +0000
committerGerd Moellmann <gerd@gnu.org>2000-07-10 20:37:48 +0000
commit7960d0bd651978e49f598bff9575fa38ec175477 (patch)
treec00d1e41c74e93c539958957f3177362c62d09d1 /configure.in
parentd65b0571381bbd2ddf939a250796d445fa519535 (diff)
downloademacs-7960d0bd651978e49f598bff9575fa38ec175477.tar.gz
(HAVE_XPM): Undo previous change. Check for
preprocessor define XpmReturnAllocPixels.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 87a353ba0b9..f91c3da4270 100644
--- a/configure.in
+++ b/configure.in
@@ -1766,7 +1766,15 @@ if test "${HAVE_X11}" = "yes"; then
old_c_flags="${CFLAGS}"
CFLAGS="${LD_SWITCH_X_SITE}"
AC_CHECK_HEADER(X11/xpm.h,
- AC_CHECK_LIB(Xpm, XpmReturnAllocPixels, HAVE_XPM=yes, , -lX11))
+ AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
+ if test "${HAVE_XPM}" = "yes"; then
+ AC_EGREP_CPP(no_return_alloc_pixels,
+ [#include "X11/xpm.h"
+#ifndef XpmReturnAllocPixels
+no_return_alloc_pixels
+#endif
+ ], HAVE_XPM=no, HAVE_XPM=yes)
+ fi
CFLAGS="${old_c_flags}"
fi