summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e71fbc37919..f364f685be9 100644
--- a/configure.in
+++ b/configure.in
@@ -125,6 +125,18 @@ AC_ARG_ENABLE(carbon-app,
specify install directory for Emacs.app on Mac OS X]],
[ carbon_appdir_x=${enableval}])
+AC_ARG_ENABLE(maintainer-mode,
+[ --enable-maintainer-mode enable make rules and dependencies not useful
+ (and sometimes confusing) to the casual installer],
+ USE_MAINTAINER_MODE=$enableval,
+ USE_MAINTAINER_MODE=no)
+if test $USE_MAINTAINER_MODE = yes; then
+ MAINT=
+else
+ MAINT=#
+fi
+AC_SUBST(MAINT)
+
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessarily, since pwd can
#### give you automounter prefixes, which can go away. We do all this