summaryrefslogtreecommitdiff
path: root/src/hunspell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hunspell/Makefile.am')
-rw-r--r--src/hunspell/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/hunspell/Makefile.am b/src/hunspell/Makefile.am
new file mode 100644
index 0000000..b31de26
--- /dev/null
+++ b/src/hunspell/Makefile.am
@@ -0,0 +1,21 @@
+if WITH_HUNSPELL
+target_lib = libenchant_hunspell.la
+else
+target_lib =
+endif
+
+AM_CPPFLAGS = -I$(top_srcdir) $(ISYSTEM)$(top_builddir)/lib $(ISYSTEM)$(top_srcdir)/lib -I$(top_srcdir)/src $(ENCHANT_CFLAGS) $(HUNSPELL_CFLAGS) $(WARN_CXXFLAGS) -D_ENCHANT_BUILD=1
+
+hunspell_LTLIBRARIES = $(target_lib)
+hunspelldir= $(libdir)/enchant
+
+libenchant_hunspell_lalibdir=$(libdir)/enchant
+libenchant_hunspell_la_LIBADD= $(HUNSPELL_LIBS) $(ENCHANT_LIBS) $(top_builddir)/src/libenchant.la
+libenchant_hunspell_la_LDFLAGS = -module -avoid-version -no-undefined
+
+libenchant_hunspell_la_SOURCES = \
+ hunspell_checker.cpp
+
+EXTRA_DIST= \
+ libenchant_hunspell.rc
+