summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Aguirre <aguirre.nicolas@gmail.com>2016-03-18 08:56:59 +0100
committerCedric Bail <cedric@osg.samsung.com>2016-03-18 10:17:49 -0700
commit290fc88e3f375a2b5054780bd797be11ad526d90 (patch)
tree447cbf9236d7639bf7306acdd2302ce10b785cca /Makefile.am
parent652895ad4ab33be714152adee85eeb7883c06593 (diff)
downloadefl-290fc88e3f375a2b5054780bd797be11ad526d90.tar.gz
evas: add eglfs evas module.
EGL Fullscreen is a module intended to support many proprietary GL driver that come with custom API to create framebuffer/window. This one is starting by covering Android with libhybris/hwcomposer. Later on, it should be able to support easily the Raspberry Pi driver. At this moment this does not work properly. Activate it at your own risk ! Do not report bug if you don't know what you are doing :-) A backend for Ecore_Evas will come later on along with a patch for Ecore_FB to use libinput. Finally a few patch should hopefully enable this backend to work and compile more easily (relying on proper header detection and dlopen/dlsym for access to proprietary function). You can read more about the goal of this patch by reading our wiki at : https://phab.enlightenment.org/w/boot2efl/ Signed-off-by: Cedric Bail <cedric@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8206b161b8..ef7c8a4292 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -188,6 +188,10 @@ if BUILD_ENGINE_FB
pkgconfig_DATA += pc/evas-fb.pc
endif
+if BUILD_ENGINE_EGLFS
+pkgconfig_DATA += pc/evas-eglfs.pc
+endif
+
if BUILD_ENGINE_BUFFER
pkgconfig_DATA += pc/evas-software-buffer.pc
endif