summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 17:27:11 +0000
committerGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 17:27:11 +0000
commit2703b747a36d81a75e373b4a4066bc179717592a (patch)
tree63b1c265e79a190ad70287209212feafdaf68b14 /Makefile.am
parent9ec7d338a2be6a9d26e9662a3dde55954c1f3019 (diff)
downloadefl-2703b747a36d81a75e373b4a4066bc179717592a.tar.gz
efl: eet and eo are now mandatory.
I've reordered the build to be: eina -> eo -> eet as it make more sense. SVN revision: 77766
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index ba69d93fd3..527213986c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,15 +57,10 @@ if HAVE_WINDOWS
pkgconfig_DATA += pc/evil.pc
endif
-pkgconfig_DATA += pc/eina.pc
-
-if EFL_BUILD_EET
-pkgconfig_DATA += pc/eet.pc
-endif
-
-if EFL_BUILD_EO
-pkgconfig_DATA += pc/eo.pc
-endif
+pkgconfig_DATA += \
+pc/eina.pc \
+pc/eo.pc \
+pc/eet.pc
.PHONY: doc benchmark examples install-examples
@@ -100,12 +95,8 @@ check-local:
if EFL_ENABLE_COVERAGE
@$(MAKE) $(AM_MAKEFLAGS) lcov-reset
endif
-if EFL_BUILD_EET
@./src/tests/eet/eet_suite$(EXEEXT)
-endif
-if EFL_BUILD_EO
@./src/tests/eo/eo_suite$(EXEEXT)
-endif
if EFL_ENABLE_COVERAGE
@$(MAKE) $(AM_MAKEFLAGS) lcov-report
endif
@@ -117,9 +108,7 @@ endif
benchmark:
@$(MAKE) $(AM_MAKEFLAGS) -C src benchmark
@mkdir benchmark || true
-if EFL_BUILD_EO
@cd benchmark && ../src/benchmarks/eo/eo_bench$(EXEEXT) `date +%F_%s`
-endif
benchmark-e17:
@$(MAKE) $(AM_MAKEFLAGS) -C src benchmark-e17