summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Philippe Andre <jp.andre@samsung.com>2017-05-30 11:02:05 +0900
committerJean-Philippe Andre <jp.andre@samsung.com>2017-05-30 11:02:05 +0900
commitbc38a4c6399a15006163fa0702f9a628ec626cc3 (patch)
tree08844818a2254904285d3606008a04316c44f6c8 /configure.ac
parentfa944c700eeaa909ff4883296fbf484fcbb41e65 (diff)
downloadefl-bc38a4c6399a15006163fa0702f9a628ec626cc3.tar.gz
check: Bump version to 0.9.10 and change macro
Changing ck_assert_ptr_nonnull() to ck_assert_ptr_ne() in order to require "only" check >= 0.9.10. ck_assert_ptr_nonnull() was introduced in 0.11.0. ck_assert_ptr_ne() is already used a lot in the test suite so a recent version of check is required.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 12d7f26012..a3240180b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -380,7 +380,7 @@ AM_CONDITIONAL([EFL_ENABLE_COVERAGE], [test "${want_coverage}" = "yes"])
# check unit testing library
if test "${want_tests}" = "yes"; then
- PKG_CHECK_MODULES([CHECK], [check >= 0.9.5])
+ PKG_CHECK_MODULES([CHECK], [check >= 0.9.10])
fi
AM_CONDITIONAL([EFL_ENABLE_TESTS], [test "${want_tests}" = "yes"])