summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Michael <cp.michael@samsung.com>2014-09-18 11:30:56 -0400
committerChris Michael <cp.michael@samsung.com>2014-09-22 14:18:53 -0400
commitf51b219762d970157c0a15a9332ac3d8b8ff6f3d (patch)
tree902ff2d315533626f45c660bc90809448f440ecb /configure.ac
parent7a02b1057324cdc8665e0672369d624a4cf2c49a (diff)
downloadefl-f51b219762d970157c0a15a9332ac3d8b8ff6f3d.tar.gz
efl: Move Eldbus above Ecore_Drm
Sumary: Ecore_Drm will use Eldbus library for dbus functionality, so we need to check for Eldbus first before Ecore_Drm @fix Signed-off-by: Chris Michael <cp.michael@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac74
1 files changed, 38 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 6946c0d479..4b741be2cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2861,6 +2861,44 @@ EFL_EVAL_PKGS([ECORE_WAYLAND])
EFL_LIB_END_OPTIONAL([Ecore_Wayland])
#### End of Ecore_Wayland
+
+#### Eldbus
+EFL_LIB_START([Eldbus])
+
+### Additional options to configure
+
+### Default values
+
+### Checks for programs
+
+## Compatibility layers
+EFL_PLATFORM_DEPEND([ELDBUS], [evil])
+
+### Checks for libraries
+EFL_INTERNAL_DEPEND_PKG([ELDBUS], [ecore])
+EFL_INTERNAL_DEPEND_PKG([ELDBUS], [eo])
+EFL_INTERNAL_DEPEND_PKG([ELDBUS], [eina])
+
+EFL_DEPEND_PKG([ELDBUS], [DBUS], [dbus-1])
+
+EFL_EVAL_PKGS([ELDBUS])
+
+### Checks for header files
+
+### Checks for types
+
+### Checks for structures
+
+### Checks for compiler characteristics
+
+### Checks for linker characteristics
+
+### Checks for library functions
+
+EFL_LIB_END([Eldbus])
+#### End of Eldbus
+
+
#### Ecore_Drm
EFL_LIB_START_OPTIONAL([Ecore_Drm], [test "${want_drm}" = "yes"])
@@ -3881,42 +3919,6 @@ if test "x${want_eo_id}" = "xyes" ; then
AC_DEFINE([HAVE_EO_ID], [1], [Have eo id])
fi
-#### Eldbus
-EFL_LIB_START([Eldbus])
-
-### Additional options to configure
-
-### Default values
-
-### Checks for programs
-
-## Compatibility layers
-EFL_PLATFORM_DEPEND([ELDBUS], [evil])
-
-### Checks for libraries
-EFL_INTERNAL_DEPEND_PKG([ELDBUS], [ecore])
-EFL_INTERNAL_DEPEND_PKG([ELDBUS], [eo])
-EFL_INTERNAL_DEPEND_PKG([ELDBUS], [eina])
-
-EFL_DEPEND_PKG([ELDBUS], [DBUS], [dbus-1])
-
-EFL_EVAL_PKGS([ELDBUS])
-
-### Checks for header files
-
-### Checks for types
-
-### Checks for structures
-
-### Checks for compiler characteristics
-
-### Checks for linker characteristics
-
-### Checks for library functions
-
-EFL_LIB_END([Eldbus])
-#### End of Eldbus
-
#### Efreet
EFL_LIB_START([Efreet])