summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Kolesa <daniel@octaforge.org>2018-08-01 13:31:15 -0400
committerMike Blumenkrantz <zmike@samsung.com>2018-08-01 13:31:15 -0400
commit9d9a3e87c8c29740dd0c143e2125ceb0eb6cdf5e (patch)
treef4cd7ad9f55dfe636f2285b60171965e0aa23592 /configure.ac
parent3ede74a8fccba3c708398ced0da67366d5ebe293 (diff)
downloadefl-9d9a3e87c8c29740dd0c143e2125ceb0eb6cdf5e.tar.gz
build: disable Lua binding generation
Summary: As Lua bindings don't work right now, it is pointless to waste build time generating them. Elua itself on the other hand is useful and should stay enabled. This also does some preparation work for separate configure switch for bindings after release, but for now keep configure switches as they are. Reviewers: zmike, stefan_schmidt Subscribers: cedric, bu5hm4n, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D6721
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b73e753c87..1a2f89d016 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5190,17 +5190,28 @@ AC_ARG_ENABLE([elua],
fi
],
[want_elua="yes"])
+
+# turn this into an AC_ARG_ENABLE when bindings are reenabled
+want_lua_bindings="no"
+
have_elua="yes"
+have_lua_bindings="yes"
+
if test "${want_lua_old}" = "yes" -o "x$want_elua" = "xno"; then
have_elua="no"
fi
+if test "x$have_elua" = "xno" -o "x$want_lua_bindings" = "xno"; then
+ have_lua_bindings="no"
+fi
+
+AM_CONDITIONAL([HAVE_ELUA], [test "x${have_elua}" = "xyes"])
+AM_CONDITIONAL([HAVE_LUA_BINDINGS], [test "x${have_lua_bindings}" = "xyes"])
+
EFL_LIB_START_OPTIONAL([Elua], [test "${have_elua}" = "yes"])
### Default values
-AM_CONDITIONAL([HAVE_ELUA], [test "x${have_elua}" = "xyes"])
-
### Additional options to configure
### Checks for programs