summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Kolesa <daniel@octaforge.org>2019-03-18 12:13:41 +0100
committerXavi Artigas <xavierartigas@yahoo.es>2019-03-18 12:13:59 +0100
commit58b8a3d1636160a752b8792f1037b8d9f3067a48 (patch)
tree5f7ab0b0289941f756beac99c63453f80cf59fc1 /meson.build
parent3fa8bb7bad584533311753fb447321e9f333591e (diff)
downloadefl-58b8a3d1636160a752b8792f1037b8d9f3067a48.tar.gz
efl: remove EFL_EO_API_SUPPORT macro
Summary: Since we're now going to be shipping some eo classes as stable, there is no point in keeping the eo api behind a macro, and it should be enabled by default. Another case is beta classes, but those are behind the EFL_BETA_API_SUPPORT guard. This also changes includes around the place where things are clearly broken (such as an included header needing something from another header but that other header being guarded, notably efl_ui_widget.h needing focus manager but focus manager being behind beta in Elementary.h) Reviewers: zmike, cedric, bu5hm4n, stefan_schmidt, segfaultxavi Reviewed By: cedric, segfaultxavi Subscribers: segfaultxavi, #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D8322
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 061cd623c1..ed7c9ea81f 100644
--- a/meson.build
+++ b/meson.build
@@ -97,7 +97,6 @@ add_global_arguments(dev_cflags, language: 'cpp')
foreach lang : ['c', 'objc', 'cpp']
add_global_arguments('-DHAVE_CONFIG_H=1', language: lang)
add_global_arguments('-D_GNU_SOURCE=1', language: lang)
- add_global_arguments('-DEFL_EO_API_SUPPORT=1', language: lang)
add_global_arguments('-DEFL_BETA_API_SUPPORT=1', language: lang)
add_global_arguments('-DNEED_RUN_IN_TREE=1', language: lang)
add_global_arguments('-DEFL_BUILD=1', language: lang)
@@ -470,7 +469,6 @@ efl_config_h.set('EFL_VERSION_MICRO', version_micro)
efl_config_h.set('EFL_BUILD_ID', get_option('build-id'))
#FIXME placeholder
-efl_config_h.set('EFL_API_EO_DEF', '#define EFL_API_EO_DEF "FIXME NOT IMPLEMENTED"')
efl_config_h.set('EFL_API_LEGACY_DEF', '#define EFL_API_LEGACY_DEF "FIXME NOT IMPLEMENTED"')
configure_file(