summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Kolesa <d.kolesa@samsung.com>2018-12-09 22:31:30 +0100
committerDaniel Kolesa <d.kolesa@samsung.com>2018-12-14 11:18:15 +0100
commit6e11153ef7a89d1205736567eb7df2a16ec67369 (patch)
tree77e877de72f8685826bc148b48a8a83ff88679f3 /meson.build
parent10819b4ea522915a88abfe065a93d25bfa9a14d6 (diff)
downloadefl-6e11153ef7a89d1205736567eb7df2a16ec67369.tar.gz
meson: fix build on power/ppc targets with altivec enabled
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 96f11d3ad2..d3dfd54424 100644
--- a/meson.build
+++ b/meson.build
@@ -157,7 +157,7 @@ if get_option('native-arch-optimization')
message('ARM64 build - NEON + intrinsics enabled')
elif host_machine.cpu_family() == 'ppc' or host_machine.cpu_family() == 'ppc64'
config_h.set10('BUILD_ALTIVEC', true)
- add_global_arguments('-maltivec-vectorize', language: 'c')
+ add_global_arguments('-ftree-vectorize', language: 'c')
add_global_arguments('-maltivec', language: 'c')
message('PPC/POWER build - ALTIVEC enabled')
endif