summaryrefslogtreecommitdiff
path: root/src/modules/elementary/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2018-08-12 15:26:29 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-02 17:22:50 +0200
commit46d464e5bfc10398461a33a2256c1c58d509dd1a (patch)
tree8c1a9272c05f14033a4430bc122632461bd73608 /src/modules/elementary/meson.build
parent70ecf1056bb4be5a68b63044f938ccc2fe0a58c0 (diff)
downloadefl-46d464e5bfc10398461a33a2256c1c58d509dd1a.tar.gz
here comes meson
a new shiny buildtool that currently completes in the total of ~ 4 min.. 1 min. conf time 2:30 min. build time Where autotools takes: 1:50 min. conf time 3:40 min. build time. meson was taken because it went quite good for enlightenment, and is a traction gaining system that is also used by other mayor projects. Additionally, the DSL that is defined my meson makes the configuration of the builds a lot easier to read. Further informations can be gathered from the README.meson Right now, bindings & windows support are missing. It is highly recommented to use meson 0.48 due to optimizations in meson that reduced the time the meson call would need. Co-authored-by: Mike Blumenkrantz <zmike@samsung.com> Differential Revision: https://phab.enlightenment.org/D7012 Depends on D7011
Diffstat (limited to 'src/modules/elementary/meson.build')
-rw-r--r--src/modules/elementary/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/modules/elementary/meson.build b/src/modules/elementary/meson.build
new file mode 100644
index 0000000000..ed77fe240e
--- /dev/null
+++ b/src/modules/elementary/meson.build
@@ -0,0 +1,14 @@
+mods = [
+ 'access_output',
+ 'clock_input_ctxpopup',
+ 'prefs',
+ 'test_entry',
+ 'test_map',
+ join_paths('web', 'none')
+]
+
+foreach mod : mods
+ mod_install_dir = join_paths(dir_lib, 'elementary', 'modules', mod, version_name)
+ subdir(mod)
+ module_files += join_paths(mod_install_dir, 'lib'+mod+'.'+sys_mod_extension)
+endforeach