summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c72bb32dbb..fe8539fa69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2088,7 +2088,6 @@ AC_CHECK_HEADERS([ \
arpa/inet.h \
langinfo.h \
features.h \
-net/if.h \
netinet/in.h \
netinet/tcp.h \
sys/prctl.h \
@@ -2102,6 +2101,21 @@ sys/un.h \
#endif
])
+AC_CHECK_HEADERS([net/if.h], [], [],
+[#include <stdio.h>
+#if STDC_HEADERS
+# include <stdlib.h>
+# include <stddef.h>
+#else
+# if HAVE_STDLIB_H
+# include <stdlib.h>
+# endif
+#endif
+#if HAVE_SYS_SOCKET_H
+# include <sys/socket.h>
+#endif
+])
+
### Checks for types
### Checks for structures