summaryrefslogtreecommitdiff
path: root/src/examples/elementary/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/elementary/Makefile.am')
-rw-r--r--src/examples/elementary/Makefile.am54
1 files changed, 24 insertions, 30 deletions
diff --git a/src/examples/elementary/Makefile.am b/src/examples/elementary/Makefile.am
index 35f7377f2c..db16bab824 100644
--- a/src/examples/elementary/Makefile.am
+++ b/src/examples/elementary/Makefile.am
@@ -1,4 +1,9 @@
MAINTAINERCLEANFILES = Makefile.in
+DISTCLEANFILES = \
+codegen_example_generated.c \
+codegen_example_generated.h \
+codegen_example.edj
+
include ../../../Makefile_Elm_Helpers.am
include ../../Makefile_Edje_Helper.am
@@ -54,6 +59,7 @@ LDADD = \
-lm \
$(top_builddir)/src/lib/eina/libeina.la \
$(top_builddir)/src/lib/eo/libeo.la \
+$(top_builddir)/src/lib/efl/libefl.la \
$(top_builddir)/src/lib/eet/libeet.la \
$(top_builddir)/src/lib/evas/libevas.la \
$(top_builddir)/src/lib/ecore/libecore.la \
@@ -177,13 +183,10 @@ efl_thread_3.c \
efl_thread_4.c \
efl_thread_5.c \
efl_thread_6.c \
-efl_thread_win32_1.c \
-efl_thread_win32_2.c \
-efl_thread_win32_3.c \
-efl_thread_win32_4.c \
efl_ui_list_example_1.c \
-efl_ui_list_example_2.c \
-efl_ui_list_example_3.c
+efl_ui_view_list_example_1.c \
+efl_ui_view_list_example_2.c \
+efl_ui_view_list_example_3.c
SRCS += \
bg_cxx_example_01.cc \
@@ -214,7 +217,7 @@ evas3d_map_example.edc \
theme_example.edc \
layout_example.edc \
codegen_example.edc \
-efl_ui_list_example.edc
+efl_ui_view_list_example.edc
EDJS = $(EDCS:%.edc=%.edj)
@@ -237,14 +240,14 @@ files_DATA += \
codegen_example.edj \
evas3d_map_example.edj \
twitter_example_01.edj \
- efl_ui_list_example.edj
+ efl_ui_view_list_example.edj
CLEANFILES = \
theme_example.edj \
layout_example.edj\
evas3d_map_example.edj \
twitter_example_01.edj \
- efl_ui_list_example.edj
+ efl_ui_view_list_example.edj
clean-local:
rm -f *.epb *.cfg *.cfg.bkp
@@ -255,9 +258,7 @@ ELEMENTARY_CODEGEN_FLAGS = --prefix=codegen_example
codegen_example_generated.c codegen_example_generated.h: codegen_example.edj
$(AM_V_CODEGEN)$(ELEMENTARY_CODEGEN) $(ELEMENTARY_CODEGEN_FLAGS) $(<) elm/example/mylayout/default codegen_example_generated.c codegen_example_generated.h
-BUILT_SOURCES = codegen_example_generated.c codegen_example_generated.h
-
-codegen_example.c: codegen_example_generated.h
+codegen_example.$(OBJEXT): codegen_example_generated.h
codegen_example_SOURCES = \
codegen_example.c
@@ -268,24 +269,23 @@ codegen_example_generated.h
if HAVE_CSHARP
if HAVE_WIN32
-MCS_FLAGS := $(MCS_FLAGS)
-MCS_FLAGS += -define:WIN32
+MCSFLAGS ?=
+MCSFLAGS += -define:WIN32
endif
efl_ui_slider_mono_SOURCES = \
efl_ui_slider_mono.cs
-efl_ui_slider_mono(EXEEXT): $(efl_ui_slider_mono_SOURCES) $(am_dirstamp) $(top_builddir)/src/lib/efl_mono/libefl_mono.dll$(EXEEXT)
+efl_ui_slider_mono$(EXEEXT): $(efl_ui_slider_mono_SOURCES) $(am_dirstamp) $(top_builddir)/src/lib/efl_mono/libefl_mono.dll
@rm -f efl_ui_slider_mono$(EXEEXT)
- $(AM_V_MCS) $(MCS) $(MCS_FLAGS) -r:$(abs_top_builddir)/src/lib/efl_mono/libefl_mono.dll$(EXEEXT) -out:$@ $(filter %.cs, $(^))
+ $(AM_V_MCS) $(MCS) $(MCSFLAGS) -r:$(abs_top_builddir)/src/lib/efl_mono/libefl_mono.dll -out:$@ $(filter %.cs, $(^))
efl_ui_unit_converter_SOURCES = \
efl_ui_unit_converter.cs
-efl_ui_unit_converter: $(efl_ui_unit_converter_SOURCES) $(am_dirstamp) $(top_builddir)/src/lib/efl_mono/libefl_mono.dll
- @rm -f efl_ui_unit_converter
- $(AM_V_MCS) $(MCS) $(MCS_FLAGS) -r:$(abs_top_builddir)/src/lib/efl_mono/libefl_mono.dll -out:$@ $(filter %.cs, $(^))
-
+efl_ui_unit_converter$(EXEEXT): $(efl_ui_unit_converter_SOURCES) $(am_dirstamp) $(top_builddir)/src/lib/efl_mono/libefl_mono.dll
+ @rm -f efl_ui_unit_converter$(EXEEXT)
+ $(AM_V_MCS) $(MCS) $(MCSFLAGS) -r:$(abs_top_builddir)/src/lib/efl_mono/libefl_mono.dll -out:$@ $(filter %.cs, $(^))
endif
@@ -399,8 +399,9 @@ efl_thread_4 \
efl_thread_5 \
efl_thread_6 \
efl_ui_list_example_1 \
-efl_ui_list_example_2 \
-efl_ui_list_example_3
+efl_ui_view_list_example_1 \
+efl_ui_view_list_example_2 \
+efl_ui_view_list_example_3
#benchmark3d
#sphere-hunter
@@ -454,13 +455,6 @@ endif
if HAVE_CSHARP
-efl_ui_slider_mono_SOURCES = \
- efl_ui_slider_mono.cs
-
-efl_ui_slider_mono$(EXEEXT): $(efl_ui_slider_mono_SOURCES) $(am_dirstamp) $(top_builddir)/src/lib/efl_mono/libefl_mono.dll
- @rm -f $@
- $(AM_V_MCS) $(MCS) $(MCS_FLAGS) -r:$(abs_top_builddir)/src/lib/efl_mono/libefl_mono.dll -out:$@ $(filter %.cs, $(^))
-
examples_PROGRAMS += \
efl_ui_slider_mono \
efl_ui_unit_converter
@@ -620,7 +614,7 @@ screenshots: examples
convert $(HTML_SS_DIR)/$${SS_FILE} $(LATEX_SS_DIR)/$${SS_FILE/.png/.eps} ; \
done
-EXTRA_DIST = dict.txt layout_example.edc theme_example.edc codegen_example.edc evas3d_map_example.edc twitter_example_01.edc efl_ui_list_example.edc performance/layout.edc performance/background.png performance/target_texture.png sphere_hunter/sphere_hunter.edc sphere_hunter/score.jpg sphere_hunter/EFL_victory.png sphere_hunter/EFL_defeat.png codegen_example_generated.c codegen_example_generated.h codegen_example.edj prefs_example_01.epc prefs_example_02.epc prefs_example_03.epc prefs_example_03.edc
+EXTRA_DIST = dict.txt layout_example.edc theme_example.edc codegen_example.edc evas3d_map_example.edc twitter_example_01.edc efl_ui_view_list_example.edc performance/layout.edc performance/background.png performance/target_texture.png sphere_hunter/sphere_hunter.edc sphere_hunter/score.jpg sphere_hunter/EFL_victory.png sphere_hunter/EFL_defeat.png prefs_example_01.epc prefs_example_02.epc prefs_example_03.epc prefs_example_03.edc
if HAVE_CSHARP
EXTRA_DIST += $(MONO_SRCS)